Jump to content

My computer is still crashing with a registery error


Recommended Posts



I am not sure if anyone here can help me as my problem is not really with the software but with my computer. When running windows 7 in normal mode it doesn't take long before my lenovo B570e crashes with a registery error. I have downloaded and run wise registry cleaner at all levels in safe mode and my computer will run in safe mode. This would be sufficient for me except I need sound to do my studies online. As soon as I return my setting to normal mode it crashes again. I can not access the list of predetermined programs to uninstall any programs as soon as I do it crashes.... (I know my laptop is full of rubbish and it was when I started to try and clean out all the unwanted programs that the problems really started).   HELP PLEASE :) 

Link to comment
Share on other sites

Hello Anipi,


Based on the detailed description of your problem, I doubt that Wise Care 365 (or any other cleaner/tune up utility) will be able to fix your current issues as they are not designed to fix registry corruption that has been (most likely) caused by a rogue program installation or malware. With that said, I would recommend the following actions:


Try to restore your system to a previous working configuration using a system restore point (if available):



If the above does not work, enter safe mode and try to recover all important data files to a USB flash drive. Then use the Lenovo One-Key Recovery feature to restore your laptop to factory defaults.



Good luck,



Link to comment
Share on other sites

Thanks, I have a full back of my data but I dont think that includes the registry nor would I know how to access that. I will look at the system restore you recommend. Thank you... is there a way I can apply the driver for sound whilst in safe mode? That is the only thing I need. Many thanks for your reply, I fear you are right about the state of my registry.

Link to comment
Share on other sites

How do you know the reason is registry error? You got error message? A blue screen of death? 


I agree with admin because you have switched your issue from a known registry corruption to a single driver issue. FYI, your audio driver is probably OK. It is just not being loaded during a safe-mode boot. With that said, I doubt that enabling audio to work in safe mode will fix your real issue; however, you can try this procedure but use it at your own risk please:




Good luck,




PS: If you want to come back and provide more specific details, maybe we can help but you have to disclose all known issues to get a targeted solution/recommendation.

Link to comment
Share on other sites

Thank you for your input guys.


1) I only wanted to activate sound so that I could keep up with my studies, it had nothing to do with resolving the problem with my computer. I now have a work around, thank you.


2) I believe it is a registry problem as everytime I start my computer in normal mode it crashes and the error is titled registry error.


3) restoring to an older version didnt help but I dont have a very old copy.


4) I cannot uninstall some programs (I activated this option in safe mode) but could others.


totally at a lose, think I will need to buy an ungrade to window 8 and start afresh. :(

Link to comment
Share on other sites

Yes, that is definitely a corrupted registry! Now, what could have been the cause? Did they start right after you did something specific (ie, tried to update a driver, applied windows updates, installed a new program)? However, my first guess would be that you have encountered a corrupted driver issue or a piece of your hardware has started to fail. I would go back into safe mode and uninstall the graphics and sound drivers for starters and then try to reboot. Please understand this is just my "first" best guess. No harm in trying something easy at this point. Also, do not go out and buy that Win 8 upgrade until you are sure that it is only a software corruption. So, give this a try and let us know. Also, please provide your make/model of your computer or system specs (if self-built). Good luck.



Link to comment
Share on other sites

One more thing. Since you have your data files backed up, you could try to do either a repair install or clean install (if you have the installation disc). Either would fix a software issue but it would not fix a hardware issue (obviously). Now, if you don't have the Win 7 installation disc, they are legally available for download (if you know your Win 7 version) but the ISO must be burned to DVD and you would need the key from your COA sticker as well.

Link to comment
Share on other sites

If you have tried all of my recommendations (Lenovo One Key Restore, repair install, clean install), you have a hardware problem. And, "still crashed" tells me nothing? I have literally written a book of things for you to try and you have responded with only two words. Good luck to you because I am out of ideas.



Link to comment
Share on other sites

If you have tried all of my recommendations (Lenovo One Key Restore, repair install, clean install), you have a hardware problem. And, "still crashed" tells me nothing? I have literally written a book of things for you to try and you have responded with only two words. Good luck to you because I am out of ideas.



Hi UCanFixit, 


It is a pity my response upset you as the intent was quite the opposite. I just wanted to let you know that I wasn't getting any change in the state of my computer and that I didn't want you to waste any more of your time trying to resolve the issue. I will take it to a professional who has all the tools to fix it after the holidays. (In my country everything shuts down over August).


To respond fully to each of your comments:


1) I agree that the cleaner cannot fix my registry. I am certain it is corrupted. 


2) Restoring to a previous point... unfortunately this point is too recent and the problem (registry error as in the photo above).. still occurs. 


3) There has never been an issue with the audio driver, just that when in safe mode (the only mode that I can run) there is no audio by default. I use my computer to work and needed sound, it had nothing to do with the fault on the computer. 


4) I am pretty certain it is a registry error as the problem started when I tried to uninstall some redundant software. Now I cannot uninstall software properly (by activating this option in safe mode)... one or 2 programs uninstalled but most hang and I get the error... registry error.. by doing this I have probably made things worse, but I still have the restore point which is possibly less corrupted. I was a bit lax and didn't make a note of the programs I tried, but unless I edit the registry manually I don't think this information is of much help anyway. 


5) You asked how the problem started...like I said in my original post  .... (I know my laptop is full of rubbish and it was when I started to try and clean out all the unwanted programs that the problems really started). ...ie when uninstalling softare


6) I removed all startup programs as you suggested and started in normal mode. This resulted in the same error.. registry error... see photo above ... I was disappointed at this as I had high hopes for this one. Hence my short reply.


7) Lenova one key recovery.... hangs and then gives me ... registry error...see photo above


8) repair install or clean install. This was my original thought but I do not have a disc. I don't fully understand your comment about the ISO being burned to the DVD nor the key from my COA sticker but without another computer I can't see how I can do this as I do not know how to burn a DVD in safemode. A clean install was the route I thought I would need to take before posting or attempt manually editing the registry. 


Sorry you were annoyed. Thank you for trying. 

Link to comment
Share on other sites

You said your system can run in safe mode, so, please open this folder (C:\Windows\Minidump) and send the latest *.dump file (the file name will be the created date) to us.

Analyze the dump file, we will know the exact crashing reason.


You said your system can run in safe mode, so, please open this folder (C:\Windows\Minidump) and send the latest *.dump file (the file name will be the created date) to us.

Analyze the dump file, we will know the exact crashing reason.

I get the message "you aren't permitted to upload this kind of file"... is that my computer blocking it as I don't have admin mode or something or coming from your security?

Link to comment
Share on other sites

Hey Anipi,
I got your dump file. Following is debugging details:



Microsoft ® Windows Debugger Version 6.12.0002.633 AMD64
Copyright © Microsoft Corporation. All rights reserved.

Loading Dump File [C:\Users\Ivan\Downloads\090214-30264-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Symbol search path is: SRV*C:\Symbols*http://msdl.microsoft.com/download/symbols
Executable search path is:
Windows 7 Kernel Version 7601 (Service Pack 1) MP (2 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS Personal
Built by: 7601.18409.amd64fre.win7sp1_gdr.140303-2144
Machine Name:
Kernel base = 0xfffff800`03202000 PsLoadedModuleList = 0xfffff800`03445890
Debug session time: Tue Sep  2 01:36:32.233 2014 (UTC - 7:00)
System Uptime: 0 days 0:06:04.889
Loading Kernel Symbols
Loading User Symbols
Loading unloaded module list
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck 51, {1, fffff8a000e56010, 5806000, 374}

Probably caused by : ntkrnlmp.exe ( nt! ?? ::NNGAKEGL::`string'+9d9a )

Followup: MachineOwner

1: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Something has gone badly wrong with the registry.  If a kernel debugger
is available, get a stack trace. It can also indicate that the registry got
an I/O error while trying to read one of its files, so it can be caused by
hardware problems or filesystem corruption.
It may occur due to a failure in a refresh operation, which is used only
in by the security system, and then only when resource limits are encountered.
Arg1: 0000000000000001, (reserved)
Arg2: fffff8a000e56010, (reserved)
Arg3: 0000000005806000, depends on where Windows bugchecked, may be pointer to hive
Arg4: 0000000000000374, depends on where Windows bugchecked, may be return code of
HvCheckHive if the hive is corrupt.

Debugging Details:




PROCESS_NAME:  mscorsvw.exe


LAST_CONTROL_TRANSFER:  from fffff800035a8158 to fffff80003277bc0

fffff880`18b5d8c8 fffff800`035a8158 : 00000000`00000051 00000000`00000001 fffff8a0`00e56010 00000000`05806000 : nt!KeBugCheckEx
fffff880`18b5d8d0 fffff800`03510c95 : 00000000`000046af 00000000`0002c02f fffff8a0`00e56010 00000000`00000004 : nt! ?? ::NNGAKEGL::`string'+0x9d9a
fffff880`18b5d930 fffff800`03510a6c : fffff8a0`00e56010 fffff8a0`00e56010 fffff8a0`025ba100 00000000`05208da0 : nt!HvMarkDirty+0x176
fffff880`18b5d990 fffff800`034f8188 : fffff8a0`00e56010 00000000`0485e3a0 fffff8a0`0b5e4a5c fffff8a0`0d1ad3a4 : nt!HvMarkCellDirty+0x150
fffff880`18b5d9e0 fffff800`034f7694 : 00000000`00000000 00000000`0485e3a0 fffff8a0`00e56010 01cfc688`ff70a686 : nt!CmpMarkKeyDirty+0x138
fffff880`18b5da20 fffff800`034f7498 : 00000000`00000000 00000000`0485e3a0 fffff8a0`036b35d0 01cfc688`ff70a686 : nt!CmpFreeKeyByCell+0x44
fffff880`18b5da60 fffff800`034f7cdd : fffff8a0`05198a40 fffff880`18b5db01 fffffa80`0485e3a0 00000000`0000000f : nt!CmDeleteKey+0x250
fffff880`18b5db20 fffff800`03276e53 : fffffa80`03bebb50 fffff880`00000000 fffff8a0`05198a40 00010000`00000000 : nt!NtDeleteKey+0x1f1
fffff880`18b5dbe0 00000000`77291e1a : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiSystemServiceCopyEnd+0x13
00000000`0019c6e8 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x77291e1a


nt! ?? ::NNGAKEGL::`string'+9d9a
fffff800`035a8158 cc              int     3


SYMBOL_NAME:  nt! ?? ::NNGAKEGL::`string'+9d9a

FOLLOWUP_NAME:  MachineOwner


IMAGE_NAME:  ntkrnlmp.exe


FAILURE_BUCKET_ID:  X64_0x51_nt!_??_::NNGAKEGL::_string_+9d9a

BUCKET_ID:  X64_0x51_nt!_??_::NNGAKEGL::_string_+9d9a

Followup: MachineOwner

1: kd> !process
GetPointerFromAddress: unable to read from fffff800034af000
PROCESS fffffa8003bfcb30
    SessionId: none  Cid: 0380    Peb: 7fffffdf000  ParentCid: 0778
    DirBase: 1c3db000  ObjectTable: fffff8a01107f540  HandleCount:
    Image: mscorsvw.exe
    VadRoot fffffa8005d32de0 Vads 187 Clone 0 Private 2539. Modified 3815. Locked 0.
    DeviceMap fffff8a000009830
    Token                             fffff8a006baec50
    ReadMemory error: Cannot get nt!KeMaximumIncrement value.
fffff78000000000: Unable to get shared data
    ElapsedTime                       00:00:00.000
    UserTime                          00:00:00.000
    KernelTime                        00:00:00.000
    QuotaPoolUsage[PagedPool]         0
    QuotaPoolUsage[NonPagedPool]      0
    Working Set Sizes (now,min,max)  (6724, 50, 345) (26896KB, 200KB, 1380KB)
    PeakWorkingSetSize                17110
    VirtualSize                       502 Mb
    PeakVirtualSize                   534 Mb
    PageFaultCount                    100321
    MemoryPriority                    BACKGROUND
    BasePriority                      6
    CommitCharge                      7030

        THREAD fffffa8003bebb50  Cid 0380.0a08  Teb: 000007fffffdd000 Win32Thread: fffff900c1d768f0 RUNNING on processor 1
        *** Error in reading nt!_ETHREAD @ fffffa8003ba7640





Probably caused by : ntkrnlmp.exe ( nt! ?? ::NNGAKEGL::`string'+9d9a )

Image: mscorsvw.exe


I guess, the probable reason is, when you run system on normal mode, this process mscorsvw.exe read file or registry error. You can try to disable mscorsvw.exe, or uninstall/reinstall the Microsoft .Net Framework , but I'm not sure whether it can solve this issue.

(mscorsvw.exe is precompiling .NET assemblies in the background, after installing Microsoft .NET framework on your computer, you may observe mscorsvw.exe process running in the background in the Task Manager.)


Disabling or stopping mscorsvw.exe
1,On Windows 7, you need to navigate to ‘C:\Windows\Microsoft.NET\Framework\v4.0.30319′ (assuming you’ve above .NET 4 version installed in your computer)
For 64-bit this is path: ‘C:\Windows\Microsoft.NET\Framework64\v4.0.30319
2. Click Start, type cmd in search box, right click on it, click Run as Administrator

3. Type cd/ and press Enter.
4. Now, we need to specify above mentioned path in command and type ngen.exe executequeueditems and press enter as shown below without quotes.
32-bit: “C:\Windows\Microsoft.NET\Framework\v4.0.30319\ngen.exe executeQueuedItems
64-bit: “C:\Windows\Microsoft.NET\Framework64\v4.0.30319\ngen.exe executeQueuedItems

5. Now wait for the process to precompile all assemblies, after a couple of minutes it will be completed.
6. Restart your computer, after restart, now you observe there will be no mscorsvw.exe process running in task manager.

Link to comment
Share on other sites

Thank you for your help. I am not quite sure what happened. When I logged onto my laptop to follow your instructions it was very slow to start, then it went into a self repair... it had not done this before, even when I had choosen this option I was still getting the same error. After some considerable time it loaded windows in normal mode, restoring back a few weeks. I do not understand how as the last available restore point had been more recent than this when I had tried to do this "manually" myself.,, anyway... I have been able to run in normal mode without problems for the last couple of days. Thanks again for your help, I am glad I didn't have to reinstall window 7. 

Link to comment
Share on other sites

Yes, after installing wise cleanser registry or other registry cleaner can cause issues with windows start stop working. So there are many other options before attempting to use a registry cleaner on your computer. Run a spyware and antivirus software on your pc that helps to scan your computer completely.


For more - http://free-registry-cleaner.wisecleaner.com/help/


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...