Jump to content

USB Drive doesn't show in JetSearch

Recommended Posts



I like JetSearch very much but have a serious problem. I have several USB HD drives connected to my computer. While the drives F, M, N and O show up in the JetSearch local drives list, my drive L doesn't. In windows explorer I can reach it without any problems.





Link to comment
Share on other sites

Hi Hasso :)


If you have connected the USB while WJS was started, it is not possible to not find it,

The program can not self locate new connections.
But if you shut down completely for WJS and start it again,
then there is a good chance that the USB is with :)




Link to comment
Share on other sites



How to unplug some USB as it is not for certain that WJS can squint between all USB, if you have them all connected?

(Wise: It is not to demean WJS in any ways, but one must try it out, if that's what it takes




Link to comment
Share on other sites

  • 3 months later...

I've been experiencing external HDD's disappearing from the search list for selectable drives.


I use the portable version of WJS and have the externals plugged in and active ("Power Savings" for USB is disabled so they function all the time; external HDD's do not have a power switch, they run on constant power from AC adapter).


The Disk Management shows the drives are recognized and active, I can browse manually but the option to search with WJS has disappeared.


The drives are active when I start up WJS, I don't start WJS without the drives being plugged in and active.

I've noticed since a few versions ago that this became a problem with WJS.

This became apparent around the same time OP has experienced same problem with external HDD's (via USB 2.0).


Rebooting and starting application doesn't work.

Nothing's worked to get the externals to appear in the selection like before.


Using version: Wise JetSearch 1.39.73

Updated to 1.41 and external HDD's are still not showing.


WJS with no externals recognized:



Disk Management showing recognized external HDD's:


Link to comment
Share on other sites

  • 4 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...