Jump to content

Bug: WRC cannot clean Registry entries with (one) double quote in key name


Recommended Posts

After having troubles with re-associating an image format with file extension *.webp to another image viewer I did some investigations.

I found two related file extension keys:




MIND the trailing double quote: "

The last entry is obviously nonsense. I am not sure where it comes from. Maybe some other crap software.

To get rid of it I run a DeepScan with Wise Registry Cleaner v10.7.1 and yes it found the culprit entries (see attached snapshot).

So I ticked them all and start cleaning.

Unfortunately Wise registry Cleaner was NOT able to really delete these registry entries.

I guess it is because it is confused by the (single) double quote

This is a bug. WRC should be able to completely delete them.

Can this be fixed in the next reelease.

Thank you



The exported registry (including the valid one without the double quote) entries look like

Windows Registry Editor Version 5.00


"a"="Corel Paint Shop Pro Photo.exe"









webp found issue.png

Link to comment
Share on other sites

Still NOT working on v10.7.2

I am not sure if you intended to fix the problem in v10.7.2

If yes, then I have to inform you that it is still unsolved.

Yes, when I perform a Deep Scan a greed check mark appears after "File Types" entry.

But when I look into registry then still some bad registry keys exist:

Windows Registry Editor Version 5.00


Windows Registry Editor Version 5.00




@="\"D:\\graphic\\Imagine\\Imagine64.exe\" \"%1\""


Can you really fix it in next WRC release?

Thank you


Link to comment
Share on other sites



Thanks for your feedback.

It is not a bug.

In the registry, a registry key does not exist alone. For example, registry key A has a key B associated with it in other paths. This kind of association even has multiple (C, D). WRC recognizes A as an invalid registry key based on a rule (the corresponding file does not exist, or empty key). But since B, C, D do not meet the rules for invalid registry keys, they are not listed at the same time. When running Wise Registry Cleaner to delete A, the registry is scanned again. At this time, since A no longer exists, B, C, and D comply with the rules of invalid registry keys, so they are listed. can be cleaned up. The same principle, when you scan again after the second clean, there may be a few associated invalid registry keys. Usually, this is rare, and clear 2-3 times are completely clean.

It doesn't sound very easy to understand. If you want to know if Wise Registry Cleaner has successfully deleted a registry key, it's actually quite simple. Before clicking the Clean button, right-click the item that needs to be verified, select Open in Registry Editor, and then click the Clean button. Manually refresh the Registry Editor after cleaning and you will find that the registry key has been deleted. There are exceptions, that is, registry keys created by antivirus software, which Wise Registry Cleaner does not have permission to delete.

Please try to scan and clean again.

Link to comment
Share on other sites

  • 2 weeks later...

So ok. You mean


exists because it is referenced in




is obviously nonsense. All Registry keys with double quotes are nonsense.

Can you add (at least as option) a cleaning rule which wipes all Registry keys if they contain a double quote?


Link to comment
Share on other sites



They are linked (associated), not because the name has double quotes, but because of the default value of the registry key.

The value of [HKEY_CLASSES_ROOT\.webp"] is webp"_auto_file

For example [HKEY_CLASSES_ROOT\.wdp"], its default value is wdpfile, you can find the registry key named wdpfile in [HKEY_CLASSES_ROOT]. We call [HKEY_CLASSES_ROOT\.wdp"] already connected [HKEY_CLASSES_ROOT\wdpfile"].



Let's get back to your question, [HKEY_CLASSES_ROOT\.webp"].

When you run Wise Registry Cleaner to scan the registry for the first time, WRC detects that the value of [HKEY_CLASSES_ROOT\webp"_auto_file\shell\open\command] is invalid (the file/folder does not exist.) and displays it in the deleteable list middle.

Why can't WRC detect [HKEY_CLASSES_ROOT\.webp"] at this point? Because [HKEY_CLASSES_ROOT\webp"_auto_file] still exists. These 2 registry keys are related.



When you run Wise Registry Cleaner again to scan the registry, you will see [HKEY_CLASSES_ROOT\webp"_auto_file] displayed in the list to delete because all values for this key are empty.

When you run Wise Registry Cleaner for the third time to scan the registry and use DEEP SCAN, you will see [HKEY_CLASSES_ROOT\.webp"] displayed in the list to delete, but marked as unsafe and you will need to manually select it.

Registry in the Windows system is very very important. Deleting a registry key or value by mistake may lead to system failure or even failure to start. Therefore, the strategy we take when cleaning the registry is to prefer to delete less and to ensure the stability and security of the system.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...