Jump to content

Running WDC portable remotely via psexec doesn't work correctly


Recommended Posts

I've been playing around with trying to use WDC remotely on machines without pestering the user of the PC and I've noticed what I think is a bug in language handling, and maybe the handling of the config file.


If I run WDC from the screen on a machine it correctly opens in Spanish and displays the options I have selected. I am running the exe from a command prompt and have CD'd to the directory where WDC is stored. So far so good.


However if I use psexec to remotely connect to the same machine and cd to the directory and then type WiseDiskCleaner.exe -a it opens on the console of the machine, but in english. It also displays the notifications about having sucessfully run, which I think I have disabled.


It makes no difference if I connect as the logged in user or as the administrator account, it does exactly the same.


Has anyone tried using WDC via script or psexec, or remote execution of any kind?


This problem can be reproduced by doing the following from your own PC:


Download psexec from microsoft (www.sysinternals.com)

Open a cmd window

psexec -u <localhost>\<local admin> \\<pcname> cmd

once you have the remote command shell open

cd c:\wisediskcleaner\   (or where ever it is)

wisediskcleaner -a



this will launch the exe remotely but the systray icon displays on the console of the PC, as does the sucess message.

Link to comment
Share on other sites

  • 1 month later...

I can confirm that this version behaves as expected. Thanks for the quick response.


I have noticed that the spanish translation contains some texts which make no sense. When the autoclean terminates it displays a small popup in the users systray which displays the text found in the [autoclean] section of the ini file

The current text makes no sense at all when displayed. Instead it should read something more like the following:


DiskSaved= de espacio liberado
TraceCleanned= ficheros han sido limpiados.

also, the popup displays a number before each text, without any space. So the text displayed would be something like "10Gbspace freed up", rather than "10Gb space freed up". Hence I've inserted spaces, but I don't know if they get picked up.




-- Ian

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...