Jump to content

NSIS Error

Recommended Posts

Hi and welcome, Kannampilly :)


1. Click Start button

2. Type cmd in the search box (above the Start button) and Enter

3. Copy and paste the below standing in the box and Enter


    C:\>icacls C:\ /setintegritylevel H


    Notice: You can change the C: \ with the drive where you have the problem


4. Try to re-installer the program


I hope it helps. :)

Link to comment
Share on other sites

Looks like you have lost an environment variable - "%temp%". 

Please follow the steps below to check it.

1. Press "Win+R" or "start - Run".

2. Type "%temp%" and click "OK".

Normally, you should open a folder like "C:\Users\<your user name>\AppData\Local\Temp". 

If windows can't open any folder or has opened a wrong folder. 

Please follow the following steps to fix the issue.

1. Click "start - All programs - accessories".

2. Right click "Command Prompt" - "Run as administrator".

3. Type the command - set temp="C:\Users\<your user name>\AppData\Local\Temp". (Please replace <Your user name> to your real user name.)

Another method:

1. Right-click "Computer" (On the desktop) - " Properties"

2. Go to "advanced settings" and click " Environment Variables" to open the next window.

3. Click "Add" button to add the variable - "temp" and set the value to "%USERPROFILE%\AppData\Local\Temp".

4. Click "OK" to save changes.

Now you can try to install the software again.




Link to comment
Share on other sites



I tried all three ways without any success.


1. The Folder "Temp" was opened in User\AppData\Local\ but I could not instal the update for VLC not any other program. Only Defender updates seem to be updated.


2. Followed your instructions and opened Command Prompt as Administrator and typed the command given by you. The command prompt returned to C:\SAI 01\ but when I tried to install a program I got:



Error 5: Access is denied"


3. When using the third method, I notice that unlike the screenshot that you sent, the values shown in my Environment Variables are as follows:

Variable Value

Data_FuncRetVal True

Temp %UserProfile%\AppData\Local\Temp

Tmp %UserProfile%\AppData\Local\Temp


I used "New" to change the Temp and TMP values as advised and closed and re-opened the Environment Variables to make sure that the changes have been registered, but there is no change in the situation.


Please help. I am re-booting to see if that will make a difference after the changes. If the problem has been solved, I shall login and inform you.


Thanks and regards,




Link to comment
Share on other sites



Hope you could make sense of the last message that seems to have lost formatting in transmission.


In desperation I used System Restore and went back to the earliest one seen - 02 Aug 2013. After that was done I had to reload CCleaner and tried doing so as Administrator from D: drive where I store such software. It was installed without any problem!


I downloaded VLC again, tried installing as Administrator from \Downloads in C: and got the same error message. Then I moved the exe file to D: and tried from there as Administrator and the update installed without any problem!


However, I require a solution to the problem as updates (other than for Windows) from Lenovo etc. that install directly are not going through and show error.


Can I send my send my yesterday's reply as a Word file as an attachment by e-mail, so that it will make sense?


With regards,



Link to comment
Share on other sites

  • 2 weeks later...

Hi Kannampilly,

I'm sorry for delay!

Based on your description, I’m 98% sure that your anti-virus software or firewall may have blocked the installer from executing the file "is-GLMTD.tmp” it released temporarily. (The file name may vary in every installation.) Please turn off your anti-virus or firewall before the installation begins.

This is why you can install the program to drive D, but can't install it to drive C.

Any troubles, please let me know.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...