Jump to content
ineuw

How to set cleaner to ignore a registry entry

Recommended Posts

TextPad's registry setting of replacing Notepad is cleared each time  I run Wise Registry cleaner.

 

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\Notepad.exe\Debugger "C:\Program Files\TextPad 8\TextPad.exe" -n : Notepad.exe has been hijacked by "C:\Program Files\TextPad 8\TextPad.exe" -n.

 

How can I list this in the Settings to ignore this key?

Share this post


Link to post
Share on other sites

Xilo, thanks for the reply. I was aware that I can ignore the item, but do I have to select 'ignore' each time the Registry cleaner is used or can I store the information in the Settings\Exclusions. . .  and in what format?

Share this post


Link to post
Share on other sites

It should be always excluded for next scans (if you don't uninstall the program, or if you don't remove the exclusion.dat from the program folder).

Does it reappear?

 

That's why I asked you to post a screenshot: I never saw that message.

Share this post


Link to post
Share on other sites

My apologies. Didn't understand why you needed a screenshot. There are two links below. to the jpg screenshots of my setup. Nothing was moved or reinstalled, but the registry key in question is checked each time I run a registry scan.

 

Wiseexclusionreappears1.jpg  Wiseexclusionreappears2.jpg

Share this post


Link to post
Share on other sites

I tried it and it doesn't find the item again.
I've set the Debugger string value in this way (exported by regedit to notepad):

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\Notepad.exe]
"Debugger"="\"D:\\Applicazioni\\HippoEDIT 1.6.31 PRO portable\\hippoedit.exe\" -n"
I used hippoedit (because I have the portable version) instead of textpad (which I didn't install).
It indeed opened hippoedit when I tried to open notepad.
I scanned image file execution only and WRC found two (same) items.

(It should have found one item only...).
I ignored one of them and at next scan the item didn't appear.

immagine.jpg

To ignore items: select the item, then ignore it.
If you only right-click the item, it won't be selected: you won't ignore it even if you click "ignore this item".

Share this post


Link to post
Share on other sites

Thanks again for your efforts in installing the software just to test it, but the solution doesn't work for me. (A Windows 7 Pro 32bit desktop). I understood your instructions perfectly regarding the selection and the application of ignore, but the setting does not stick. To be sure, I tried all possibilities.

 

What does work is if I deselect the Image File execution in the Custom scanning. I realize that this solution has a serious drawback, but this is the only application that is listed in the Image File execution. Also, this is a single user computer, and I have all the needed software tools and plan no new software installations for the foreseeable future, I took the risk.

 

Thanks again.

 

Share this post


Link to post
Share on other sites

Hey ineuw,
Sorry for the delay.
And, thanks xilolee.

 

There are 2 ways to ignore a specify item(registry)
1, Right click on the item, click Ignore Selected Entry
2, Click Settings (the spanner icon), click Exclusion, Add a Keyword, then enter HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\Notepad.exe\, click Save button to save and exit.

 

It won't list it again, unless you uninstall wise registry cleaner.

 

BTW, I installed TextPad 8.1.1 in my Windows 7 32bit system, but I didn't find this registry entry in registry.
Please try my methods again.

Share this post


Link to post
Share on other sites

Hi,

 

To activate the Notepad replacement you find the setting on the Preferences\General tab.

 

Unfortunately, neither of the possibilities work for me as you can see in the attached images. They do nothing. The cleanup removes this registry setting no matter what I do.

 

In Wise \Settings\Exclusion panel, I added the keyword "textpad", followed by a space and then pasted "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Image File Execution Options\Notepad.exe\". But, I have my doubts if this is correct. Please examine the attached screenshot.

 

Currently, I manually deselect this each time I run the registry cleaner, since I realized that disabling the key is a very dangerous thing to do.

 

 

 

post-41335-0-62661700-1484072685_thumb.jpg

post-41335-0-65999900-1484072702_thumb.jpg

post-41335-0-71712100-1484072711_thumb.jpg

Share this post


Link to post
Share on other sites

Thanks for your attaching the image of the exclusion panel. The exclusion works in Wise 365 on the first cleaning, and the Registry Cleaner on the SECOND cleaning. One of my problems was the wording "Keyword" is misleading.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×